Tietopankki
Concrete5 PHP 7 yhteensopivuus ongelma
Lähettänyt Jomi Olkkonen on 09 February 2018 09:32 AM

Concrete5 ei ole suoraan yhteensopiva PHP 7 kanssa. Ongelma aiheuttaa alla olevan kuvan mukaisen virheilmoituksen.

https://staticweb.zoner.fi/tuki/webhotellit/concrete/concrete_virhe.jpg

Ongelma on korjattavissa aktivoimalla Concretesta tietokantaperusteiset istunnot.

Webhotellista voidaan myös vaihtaa käyttöön PHP 5.6:

https://tuki.zoner.fi/index.php?/Knowledgebase/Article/View/101/1/php-version-valitseminen

 

 

1. Istunto tyypin vaihtaminen onnistuu concrete.php tiedostosta.

Concreten 8.3.2 versiossa tiedosto löytyy /concrete/config/ kansiosta.

 

2. Etsintään tiedostosta sessions asetukset ja sen alta handler kohta.

Vaihdetaan file asetuksen tilalle database.

https://staticweb.zoner.fi/tuki/webhotellit/concrete/concrete.jpg

 

Vaihtoehtona on myös vaihtaa kansioita, johon sessionit tallennetaan:

https://staticweb.zoner.fi/tuki/webhotellit/concrete/concrete2.jpg

(0 ääntä)
Artikkeli oli hyödyllinen
Artikkeli ei ollut hyödyllinen

Kommentit (0)
Lähetä uusi kommentti
 
 
Koko nimi:
Sähköpostiosoite:
kommentit:
Help Desk Software by Kayako fusion
..